BackupExec 12.5 unter Debian Linux

BackupExec 12.5

Hier hat Symantec wirklich was getan und die Installation lief unter meinem Debian 4.0r5 (etch – X86) ohne Probleme. Obwohl Debian nicht auf der Liste der unterst├╝tzten Systeme steht ­čśë
Und so geht es:

  1. Das RALUS-Paket von Symantec License Portal herunterladen:
    BEWS_12.5.2213_LINUX-UNIX-MAC-SAP_AGENTS.tar.gz
  2. Paket auf der Debian-Maschine entpacken
  3. Script installralus ausf├╝hren und den Anweisungen folgen.
    Mehr dazu im Symantec Backup Exec Administratorhandbuch ab Seite 1119.

Danach ist der RALUS-Agent installiert und kann gestartet werden:

/etc/init.d./VRTSralus.init start

Die Konfiguration findest du im Ordner /etc/VRTSralus, vor allem die Datei ralus.cfg ist hier interessant.

Unter /opt/VRTSralus liegen die ausf├╝hrbaren Dateien sowie die Libs.
Es gibt noch unter /var/VRTSralus ein weiteres Verzeichnis, dieses enth├Ąlt die Log-, PID-, Datei sowie die Versionsdatei.

Neu in 12.5 ist der Linux Remote-Medienagent. Mit diesem kann man Daten auf dem an dem Server angeschlossen Laufwerken sichern. Dazu mehr im Symantec Backup Exec Administratorhandbuch ab Seite 1159.
Da ich pers├Ânlich keine Laufwerke an einem Linux-Server habe, kann ich leider nichts zu diesem Agenten sagen.

Konfigurationsdatei (BE12.5)

Nun gucken wir aber noch in die ralus.cfg in /etc/VRTSralus, was die Eintr├Ąge alle genau hei├čen, wei├č ich auch nicht.
Wer was dazu wei├č, bitte melden !!

Vorab steht immer „SoftwareSymantecBackup Exec For WindowsBackup Exec“ , zur besseren Darstellung habe ich das mit „…“ abgek├╝rzt:

…EngineAgentsAdvertising Interval Minutes=60
=> Alle 60 Minuten den Medienserver kontaktieren

…EngineAgentsAgent Directory List_1=backup.tuxhausen.de
=> damit steht der Linux-Server bei den Bevorzugten Ressourcen im Medienserver backup.tuxhausen.de (der Name muss aufl├Âsbar sein, sonst IP-Adresse eintragen)

…EngineRALUSSystemExclude1=/mnt/n1
=> Verzeichnis von der Sicherung ausschlie├čen, in dem Fall /mnt/n1

…EngineRALUSSystemFSTypeExclude1=devpts
=> Dateisystem von der Sicherung ausschlie├čen, hier devpts

Die folgenden Eintr├Ąge habe ich noch, bin aber nicht 100% was sie bewirken:

…Agent BrowserTcpIpAdvertisementPort=6101
… DebugAgentConfig=0
…DebugVXBSAlevel=5
…EngineAgentsAdvertise All=1
…EngineAgentsAdvertise Now=0
…EngineAgentsAdvertisement Purge=0
…EngineAgentsAdvertising
…EngineAgentsAdvertising Internal Minutes=240
…EngineAgentsAuto Discovery Enabled=1
…EngineLoggingRANT NDMP Debug Level=0
…EngineRALUSEncoder=
…EngineRALUSShowTSAFS=
..EngineRALUSVfmPath=/opt/VRTSralus/VRTSvxms

Wer eine Idee hat, bitte einen Kommentar schreiben, danke !!

Logging

Gerade wenn es klemmt ist eine Log-Ausgabe nicht falsch, der Agent kann dies auf mehreren Wegen:

  • Startest du beremote mit dem –log-console werden alle Logs auf die Konsole geschrieben
  • mit –log-file Datei werden alle Logs in Datei geschrieben (n├╝tzlich im Init-Script)
  • mit –log-file-auto werden alle Logs in Datei ins Verzeichnis┬á /var/VRTSralus geschrieben ( auchn├╝tzlich im Init-Script)

Vor eine umfangreichen Backup solltest du das Logging aber besser wieder abschalten, das wird sehr schnell sehr gro├č …

├ťbrigens nicht wundern wenn diverse libs nicht geladen werden konnten, die habe ich auch, aber das Backup ist OK ­čśë

This entry was posted in Backup Exec, Debian, Linux and tagged . Bookmark the permalink.

8 thoughts on “BackupExec 12.5 unter Debian Linux

  1. die Anleitung habe ich befolgt und alles hat wunderbar funktioniert. Wenn ich jetzt allerdings auf dem medien server mit entsprechender authenifizierung eine verbindung mit dem debian server aufbauen m├Âchte popt folgende meldung auf: Beim versuch, den Inhalt von [server] zu durchsuchen, trat ein Fehler auf. Es konnte keine Netzwerkverbindung hergestellt werden.

    Danke f├╝r einen tipp.

    Gru├č Rafael

  2. Hallo Rafael,

    ich habe gerade den Artikel erweitert, bitte versuche es mal mit dem Logging auf dem Debian-Rechner.
    Vielleicht sieht da etwas ..

    Ansonsten, es sind aber keine Firewalls oder so im Wege ??
    VG

  3. Der Agent kontaktiert den Medienserver auf Port 6101 (ÔÇŽAgent BrowserTcpIpAdvertisementPort in Config-Datei). Wenn dies geblockt wird, ist der Agent im Medienserver nicht sichtbar.

    F├╝r das Backup greift aber der Medienserver auf den Agent zu. Ich musste bei mir auf dem Linuxserver die Ports 10000 sowie 1025-1030 ├Âffnen (anhand der Firewall-Logs rausgefunden).

  4. Ich hatte den Backup Agent jetzt auch eine ganze Zeit unter ETCH laufen. Jetzt hab ich ein UPdate auf LENNY gemacht und seit dem will der VRTLralus Dienst nicht mehr anspringen. Wei├č aber auch nicht wo ich da ansetzen soll:

    /opt/VRTSralus/bin/beremote –log-console
    b5c968c0 Wed Jun 16 17:45:11 2010 : Starting BE Remote Agent
    b5c968c0 Wed Jun 16 17:45:11 2010 : Requested no generation of log file
    b5c968c0 Wed Jun 16 17:45:11 2010 : No configuration file specified. Using default.
    b5c968c0 Wed Jun 16 17:45:11 2010 : Log to console: enabled
    b5c968c0 Wed Jun 16 17:45:11 2010 : Successfully set the supplementary groups of the process
    b5c968c0 Wed Jun 16 17:45:11 2010 : Initialized locks for SSL callbacks
    b5c968c0 Wed Jun 16 17:45:11 2010 : Starting NDMP processor
    b5c968c0 Wed Jun 16 17:45:11 2010 : NDMPDMainThreadFunc spawned: grpid=1, tid=-1245340784
    b5c59b90 Wed Jun 16 17:45:11 2010 : FS_InitFileSys
    b5c59b90 Wed Jun 16 17:45:11 2010 : libbedsnt5.so could not be loaded: 0x 2 (2)
    b5c59b90 Wed Jun 16 17:45:11 2010 : libbedssql2.so could not be loaded: 0x 2 (2)
    b5c59b90 Wed Jun 16 17:45:11 2010 : libbedsxchg.so could not be loaded: 0x 2 (2)
    b5c59b90 Wed Jun 16 17:45:11 2010 : libbedsxese.so could not be loaded: 0x 2 (2)
    b5c59b90 Wed Jun 16 17:45:11 2010 : libbedsmbox.so could not be loaded: 0x 2 (2)
    b5c59b90 Wed Jun 16 17:45:11 2010 : libbedspush.so could not be loaded: 0x 2 (2)
    b5c59b90 Wed Jun 16 17:45:11 2010 : libbedsnote.so could not be loaded: 0x 2 (2)
    b5c59b90 Wed Jun 16 17:45:11 2010 : libbedsmdoc.so could not be loaded: 0x 2 (2)
    b5c59b90 Wed Jun 16 17:45:11 2010 : libbedssps2.so could not be loaded: 0x 2 (2)
    b5c59b90 Wed Jun 16 17:45:11 2010 : libbedssps3.so could not be loaded: 0x 2 (2)
    b5c59b90 Wed Jun 16 17:45:11 2010 : libbedsupfs.so could not be loaded: 0x 2 (2)
    b5c59b90 Wed Jun 16 17:45:11 2010 : libbedsshadow.so could not be loaded: 0x 2 (2)
    b5c59b90 Wed Jun 16 17:45:11 2010 : libbedsoffhost.so could not be loaded: 0x 2 (2)
    b5c59b90 Wed Jun 16 17:45:11 2010 : loaded libbedsvx.so
    b5c59b90 Wed Jun 16 17:45:11 2010 : loaded libbedsrman.so
    b5c59b90 Wed Jun 16 17:45:11 2010 : loaded libbedssms.so
    b5c59b90 Wed Jun 16 17:45:11 2010 : loaded libbedssmsp.so
    b5c59b90 Wed Jun 16 17:45:11 2010 : libbedsra.so could not be loaded: 0x 2 (2)
    b5c59b90 Wed Jun 16 17:45:11 2010 : libbedsdb2.so could not be loaded: 0x 2 (2)
    b5c59b90 Wed Jun 16 17:45:11 2010 : loaded libbedsedir.so
    b5c59b90 Wed Jun 16 17:45:11 2010 : libbedsvmesx.so could not be loaded: 0x 2 (2)
    b5c59b90 Wed Jun 16 17:45:11 2010 : Initializing FSs
    b5c59b90 Wed Jun 16 17:45:11 2010 : FS 1 failed to initialize: 0xE000FE46
    b5c59b90 Wed Jun 16 17:45:11 2010 : Function called: RMAN_InitFileSys
    b5c59b90 Wed Jun 16 17:45:11 2010 : Using ‚UTF-8‘ Encoding.
    b5c59b90 Wed Jun 16 17:45:11 2010 : Using vfm path /opt/VRTSralus/VRTSvxms from config.
    b5c59b90 Wed Jun 16 17:45:11 2010 : Sucessfully set VFM_PRIVATE_ROOT env to /opt/VRTSralus/VRTSvxms.
    b5c59b90 Wed Jun 16 17:45:11 2010 : VFM_PRIVATE_ROOT was set with value /opt/VRTSralus/VRTSvxms
    Segmentation fault

    Scheinbar hat er an der Stelle mit dem VRTSvxms irgend ein Problem und er bricht mit Segfault ab…

  5. Ich habe einen Debian Squeeze-Server und BE 12.5 SP4
    Auf 32-Bit-Servern funktioniert der Agent problemlos, auf 64-Bit st├╝rzt der Agent immer ab wenn ich in BE den Server in der Selection List ausw├Ąhle.
    Habe den Patch ralus2213HF336087-Linux64.tar_337524.gz eingespielt, bzw. die Files manuell ├╝berschrieben.
    Auch den Latin-1 im ralus.cnf habe ich eingetragen.
    Log-File gibt nichts aus…

    Meine Versionen:
    VRTSralus-12.5.2213-0.x86_64.deb
    vrtsvxmsa_4.4.021-1_amd64.deb

    Kann mir jemand helfen, ich muss diese neuen Server unbedingt sichern!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht ver├Âffentlicht. Erforderliche Felder sind mit * markiert.